Minecraft PC IP: play.cubecraft.net

Do you agree?


  • Total voters
    125
  • Poll closed .
Status
Not open for further replies.

Awabbatt

Member
Nov 14, 2020
352
415
79
Canada
www.speedrun.com
While most people are on the latest version of minecraft, some people have downgraded for various reasons and it's pretty simple if you know how, but most people don't know about it so in the end most people are on 1.17.

1627503135383.png

recently cubecraft updated to 1.16.201.




Why? Its was not needed and nobody asked for this. 1.16.0 was only about a year ago and .201 was 5 months ago. They were still fairly new and there was no bugs with them. Completely unessential to do something like this.
The most significant change is the fps, which for VR and Low end devices its downright impossible to play any version that is 1.16.201 onwards. 10fps is the most you can really get because microsoft thought it would be fun to mess around with something. And believe me most people dont have super GPUs.

Anyways this was meant to be more of a rant because I doubt that it's actually possible or they will actually do something like this. Guess I just have to go play another server.

Please react with :agree: so that the devs can actually see how much hated this decision really is and why it is a terrible idea. Also vote on the poll above.

You don't have to enable every version, just enable 1.16.40 so people on low end devices can still get an enjoyable experience.

Was this really essential?



Also I added this part because people seem to be disagreeing without understanding, just look how bad the fps is


Edit : This just got implemented :)
it can be locked now ig
 
Last edited:

Matriox

Member
Jun 15, 2020
1,148
2,546
274
Ireland
It seems on discord a lot of people were not happy with this decision, a lot of people still used this version and i dont see why they would remove support for such a popular version especially seen as a lot of people have brought forward there concerns. But at the end of the day it is Cubecraft.
 

Awabbatt

Member
Nov 14, 2020
352
415
79
Canada
www.speedrun.com
They didn't update the cubecraft servers itself to 1.16 and 1.16.201. They just added support for those versions so the players that play those versions can access the cubecraft network. Cubecraft itself is on 1.12.2 for java (I think that's the same for bedrock).
1627504143792.png

they did. they literally said "dropped" which means its no longer possible to play any version pre 1.16.201
 
  • Like
Reactions: Matriox

Jukaido

Member
Mar 18, 2020
297
1,381
139
For some people who don't understand why this is such an issue:

For people on mobile and console and low end consoles 1.17+ is unplayable since they get like 5 frames and huge lag spikes.
For people on pc they get huge input delay (for some friends of mine up to 3 seconds) and its just not enjoyable.

The reason I got for this change was "it caused bugs and glitches" which just makes no sense at all how would supporting a version cause any sort of bugs on the network? I'm not a developer myself but I could be completely wrong on this.

90+% of the competitive bedrock community uses the version 1.16.100.4 and 1.16.40, many of which are since quitting the game due to this. Which shows that the people who made this decision again didn't ask the community and especially not the long term experienced players, yes most of the nons play on the latest versions and yes they earn you the most money.

Also notice how all the "disagree" votes come from Java players or non experienced bedrock players :) no surprise at all:

I have also found a bypass to still be able to play 1.16.100/40 on cubecraft which I have shared with the competitive community so you didn't even manage to do a good job at disabling these versions

Edit: Found this old thread https://www.cubecraft.net/threads/a...r-versions-and-why.272482/page-2#post-1277806 what happened to this??
 
Last edited:

juliusvdl

Member
Apr 5, 2020
32
82
34
22
Rotterdam
I cannot play with the input delay that the 1.16.200 update brought. I simply can't. I already gave up my long term survival worlds due to this and now i have to drop cube (the only reason i still play bedrock) too?? The input delay makes my aim absolutely terrible to control and it makes competitive pvp on bedrock impossible for me. I have to literally predict where the opponent is gonna strafe to because it takes 1 second for my input to register. I'm sorry but i cant read the future. After 3 years and countless euros spent on this server, this might be the time where i am forced to quit. This can't be happening, please revert this Cube.
 

Gamenight888

Member
Aug 11, 2019
83
109
59
This was the most needless update I've ever seen. I saw a response and explanation to this in another post. Essentially, the response was "Oh, we want to move to the newer version to continue updating our server."

With what? More parkour levels? A new gamemode like prop hunt? Things like that instead of fixing the countless bugs and issues that I guarantee have been reported several times in bug reports? Taking away versions people like instead of adding helpful features recommended by players that could really make people enjoy the game more? People want to use these versions so they can play the game properly. And they're somehow expected to do so on newer version? Several people are going to quit the server now because of this update. Also another thing about the post, just because you've allowed usage of a version for slightly longer than usual doesn't mean you should just randomly drop the ability to use it out of nowhere.

Typical CubeCraft. Not even surprised anymore.
 

ProfParzival

Member
May 6, 2019
355
420
89
London, UK
www.youtube.com
I've made two posts (Here and here) about this in the past as I'm stuck on version 1.16.100 and I've read the post from redned about why there is a need to eventually drop support for older versions "cubecraft don't want to hold ourselves back forever"... As a software developer myself I get that but there are some massive issues that were introduced in 1.16.200 and newer which have been detailed by the posters above me and which Mojang / Microsoft have simply failed so far to address.

I get that you can't support older versions forever but I'd hoped that you'd want to retain as much of the player community as possible whilst other competing servers retain support for older versions... Most of the other featured servers and a number of other decent non featured servers still support 1.16.100 and I can still log on to them as of today.

So unless there were really compelling reasons to drop support for 1.16.x, and I couldn't see anything specific in redneds post, then I really don't understand why it's being dropped? What specifically is support for 1.16.100+ stopping cubecraft from doing? or what feature is it making not work? eg it would help a lot more for those of us affected if you had some really solid reasons for us rather than "it's stopping us moving forward" type answers which are quite vague.

I think there are some very very valid reasons for retaining support for at least 1.16.100+ some of which are noted in this thread and whilst I know I'm in a very very very tiny minority of bedrock players that choose to play in VR, I just wanted to add that 1.16.200 made playing Minecraft in VR almost impossible due to around 6 bugs that mojang / Microsoft have in many cases not even acknowledged let alone addressed and fixed. I'm not daft enough to think that Cubecraft should retain support simply for us VR players but I just wanted to add to the voices in this thread that I too will likely just have to say goodbye to cubecraft and go play other servers (for at least as long as they continue to support 1.16.x) if I can't even get on to the server anymore.
 

Awabbatt

Member
Nov 14, 2020
352
415
79
Canada
www.speedrun.com
My opinion: This shouldn’t be removed back to the 1.16 just cause of that like 100 people doesnt like it cause of their frames. So long as it is playable, then you shouldnt really be complaining. There are phone players that play the game. It should be more fair that pc players also get the frames of a mobile player. Like it doesnt make the game fun if a pc player gets over 200 fps with clients. Like you could really just go play cubecraft Java and you’d get rekt and dont stand a chance against other. Thats why they get their 200 fps pc and fight mobile players, but now they have to fight mobile players with almost same fps. Plus going backwards in versions is just dumb cause
you expect everyone to have a good GPU? literally go onto 1.16.200 with an average pc and ull get 5 fps at best 10fps.
 

Awabbatt

Member
Nov 14, 2020
352
415
79
Canada
www.speedrun.com
For those of you who will quit bc of this, there is a way to join in older versions which ofc i wont be telling here for obvious reasons. This just shows how they cant even update properly. dm me on discord if u wanna know. (theyll prob fix it soon tho)
 
Status
Not open for further replies.
Members Online

Members online

Latest profile posts

UncleSpect wrote on Nammed's profile.
Happy birthdayy!!
UncleSpect wrote on Priley's profile.
Happy birthdayy!!
New Christmas avatar!
Face Avatar.png
Buckyy wrote on AlexpYT192's profile.
Fue bonito mientras duró....
T.A.ACC wrote on HellIsHot's profile.
👋
Top Bottom