We now have 1.14 support!

Discussion in 'Java Edition News' started by Camezonda, Apr 23, 2019.

  1. Camezonda

    Camezonda Management
    Staff Member Management

    Messages:
    5,804
    Likes Received:
    4,842
    Trophy Points:
    368
    Camezonda
    Management
    PLUS
    Thread banner - compressed.jpg
    Hello CubeCrafters!

    As most of you know, today was the official release of the Minecraft Java 1.14 update, also known as the Village & Pillage update. Well we're also here today to celebrate our compatibility with 1.14! That's right, you can now join our Java network using 1.14. So you can have fun in a survival world, exploring and discovering the new content, and if you ever get bored, you can join CubeCraft for some more fun!

    From today, CubeCraft Games is now fully compatible with 1.8 and 1.9-1.14. So what are you waiting for?! Get on 1.14 and have some fun! When you join CubeCraft on 1.14, you will still be connecting to our 1.9+ network. The version is supported, not the content. There's always the possibilty in the future ;)


    Thanks for reading, we hope you enjoy using 1.14. Comment below and let us know what you think!
     
  2. Azalea

    Azalea Member

    Messages:
    755
    Likes Received:
    1,781
    Trophy Points:
    253
    xAzalea_
    Obsidian
    YAY 1.14
     
    Wqsknijper likes this.
  3. MauTwT

    MauTwT Member

    Messages:
    8
    Likes Received:
    2
    Trophy Points:
    18
    That's great :)
     
  4. Nikoshka

    Nikoshka Member

    Messages:
    179
    Likes Received:
    897
    Trophy Points:
    109
    Coming soonTM in Summer 2080!!
     
    GalacticAC, Riley, Sophie and 10 others like this.
  5. Basketman

    Basketman Member

    Messages:
    545
    Likes Received:
    819
    Trophy Points:
    153
    Basketman13
    Obsidian
    PLUS
    Whoop whoop.
     
  6. Alfredo_TCP

    Alfredo_TCP Member

    Messages:
    65
    Likes Received:
    58
    Trophy Points:
    78
    Alfredo_TCP
    Obsidian
    Lol awesome update . Good job
     
  7. Dutudy

    Dutudy Member

    Messages:
    1,132
    Likes Received:
    3,163
    Trophy Points:
    304
    Dutudy
    Obsidian
    noice
     
    xXIIIIIIXx likes this.
  8. iTzKikoYT_

    iTzKikoYT_ Member

    Messages:
    13
    Likes Received:
    2
    Trophy Points:
    4
    iTzKikoYT
    Obsidian
    PLUS
    :D que buenooo
     
  9. Blocky

    Blocky Member

    Messages:
    502
    Likes Received:
    1,455
    Trophy Points:
    208
    blocky12
    Lapiz
    Yay another update that offers nothing extra for cube
     
    Spuuuni, Nikoshka and Azalea like this.
  10. carrometeoro

    carrometeoro Member

    Messages:
    425
    Likes Received:
    368
    Trophy Points:
    98
    Mikioouu
    I want pvp with crossbows :c
     
    GalacticAC likes this.
  11. Megaaa

    Megaaa Member

    Messages:
    7,514
    Likes Received:
    4,491
    Trophy Points:
    338
    Megaaa
    Obsidian
    Oke so it released today, right? And Cube already supports it. If there were so fast with their ‘good’ updates. Oof Cube will be great again.
     
    Last edited: Apr 24, 2019
    carrometeoro likes this.
  12. Elivat

    Elivat Member

    Messages:
    562
    Likes Received:
    817
    Trophy Points:
    98
    DragonEli
    Emerald
    PLUS
    We’re 5 versions away from 1.9. Maybe it’s time to let some versions go, there are so many cool new mechanics like tridents and crossbows that would definitely make the game much more fun.
    Also, you should make TowerDefence 1.14+ and add all the new mobs.
    The version of the game you offer in your server is already very outdated, 1.9 was released in 2016!!!
     
    carrometeoro likes this.
  13. zCris2259_YT

    zCris2259_YT Member

    Messages:
    81
    Likes Received:
    229
    Trophy Points:
    49
    zCris2259_YT
    Obsidian
    There are a massive amount of errors (example: The slabs look like stone and when I swimming is corrupted and the animation is also corrupted and others)
     
  14. Migu3lxD

    Migu3lxD Member

    Messages:
    8
    Likes Received:
    1
    Trophy Points:
    29
    KB4
    Obsidian
  15. GalacticAC

    GalacticAC Member

    Messages:
    214
    Likes Received:
    116
    Trophy Points:
    44
    galaticAC
    Diamond
    You guys should drop anything below 1.14
    I know this takes a lot of time but you guys should start working on it
    The current version is quite bad (I mean 1.9 pvp with no armor toughness is boring..)
     
    carrometeoro likes this.
  16. Gbmq

    Gbmq Member

    Messages:
    322
    Likes Received:
    284
    Trophy Points:
    89
    Gbmqa
    Emerald
    PLUS
    They shouldn't drop anything, why reduce their player base?
     
  17. Riley

    Riley Member

    Messages:
    3,002
    Likes Received:
    7,238
    Trophy Points:
    539
    Priley
    Obsidian
    Yeah ok, but this can't be considered to be an actual update, can it?
     
  18. xXIIIIIIXx

    xXIIIIIIXx Member

    Messages:
    72
    Likes Received:
    27
    Trophy Points:
    19
    IIIIIIIII_NM
    Emerald
    Nikoshka,why you resigned from staff?
     
  19. xXIIIIIIXx

    xXIIIIIIXx Member

    Messages:
    72
    Likes Received:
    27
    Trophy Points:
    19
    IIIIIIIII_NM
    Emerald
    The update is for the game,not for the network
     
  20. CattyCat

    CattyCat Member

    Messages:
    2,430
    Likes Received:
    1,426
    Trophy Points:
    173
    Catty__Cat
    When Cubecraft supports 1.14 the day it was released:
    [​IMG]