Minecraft PC IP: play.cubecraft.net
logicalpencils
Featured content
0
Reaction score
85

Joined
Last seen

Profile posts Latest activity Postings About

  • Do you really want 1.11 shields on an EU server where our ping will be heavily against us?
    logicalpencils
    logicalpencils
    Yes - I hate 1.9 shields cuz they suck. But beyond that, I see no reason for the server to still support 1.9-1.11; before 1.9, nobody would even think about not updating to the current version as soon as possible, but now people are using the smallest excuse possible to maintain the support of older versions... Like, I can get 1.8 if you have an irrational fear of 1.9 combat, but why 1.9-1.11?
    Power Ranger
    Power Ranger
    I want them to update to 1.12 too and I think the developers are just avoiding updating so they dotn have to deal with the bugs but I don't want to be constantly destroyed by people who can raise their shield twice as fast as me. :(
  • Loading…
  • Loading…
  • Loading…
Top Bottom