i was hacked so i need to update it