1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

used version 1.7

Discussion in 'Suggestions' started by YT_Alkio_PvP_, Jun 21, 2015.

Thread Status:
Not open for further replies.
  1. YT_Alkio_PvP_

    YT_Alkio_PvP_ Member

    Joined:
    Apr 5, 2015
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    we need used version 1.7.x
     
  2. Drew McNamee

    Drew McNamee Member

    Joined:
    Jan 30, 2014
    Messages:
    2,427
    Likes Received:
    1,554
    Trophy Points:
    113
    Gender:
    Male
    Please give more details about what you are suggesting here.
     
  3. YT_Alkio_PvP_

    YT_Alkio_PvP_ Member

    Joined:
    Apr 5, 2015
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    version is better because there blockhiting and mods
    I think the blockhiting is very important in minecraft server PVP and MCSG recently put that version
     
  4. Tacosbefriends

    Tacosbefriends Admin Staff Member Administrator

    Joined:
    Jan 13, 2014
    Messages:
    6,361
    Likes Received:
    6,733
    Trophy Points:
    113
    Gender:
    Male
    Occupation:
    Snarky Internet Man
    Location:
    My Computer Desk
    Home Page:
    We've updated to 1.8 because we can take advantage of tons of new features. Most mods have updated to 1.8 and I see no reason to support an outdated version.
     
Thread Status:
Not open for further replies.