1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Server lags / crash / connection lost

Discussion in 'Bug Reports/Support' started by Martinocom, Apr 10, 2016.

  1. Martinocom

    Martinocom Member

    Joined:
    Apr 10, 2016
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Hi there!
    I spent many time on this server before the easter update, and it never did "strange things". I think after this update the server begin to get crazy: I occurred many random blocks, crashes of server and exeptions of the game.

    I don't really now what's going on, but I think after the last updates the things go bad. I don't even know if the problem is on a "on fix" state or if it never been comunicated to you. I just wanna start this topic for three reasons:
    - see if anyone else has the same problems (my friends on VoiP has, so I suppose it's a general problem)
    - tell you that there are some connection problems with server
    - just becouse it's frustrating to see entire map blocked, and someone continue to play, someone else exiting from server losing connection.

    The crashes are minimal: they lasts for 1-5 seconds, but sometimes it's just waht's needed to lose connection.
    Please, consider to fix this bug. It's really frustrating.

    The two games that "crashes" more frequently are Egg Wars and Tower Defence.
     
  2. xMegaCaviax

    xMegaCaviax Member

    Joined:
    Mar 4, 2015
    Messages:
    6,388
    Likes Received:
    2,044
    Trophy Points:
    113
    Gender:
    Male
    Occupation:
    CubeCrafter
    Location:
    ƮǿʍǿřřǿώŁąɲȡ
    Home Page:
    CubeCraft can sometimes be laggy and crash sometimes. None server can be that stable for weeks or months. But I never got the laggy things or crash reports. But did you saw if you've got good connection?
     
  3. JvwerMcGames

    JvwerMcGames Member

    Joined:
    Jan 12, 2016
    Messages:
    451
    Likes Received:
    122
    Trophy Points:
    43
    Gender:
    Male
    Location:
    The Netherlands
    if your minecraft crash. can you copy paste the crash report pls?
    I'm good with crash reports ;)
     
  4. Marco Slater

    Marco Slater Owner Staff Member Owner

    Joined:
    Oct 19, 2013
    Messages:
    1,526
    Likes Received:
    2,163
    Trophy Points:
    113
    Gender:
    Male
    Occupation:
    Pushing buttons for Digital Tree Media.
    Location:
    Bury, UK.
    Home Page:
    We can in fact have issues from time to time, no server is perfect, however its usually a rarity, most of the times its an issue between your ISP and our servers, or your internet connection on its own.

    When we do have issues, we post them on our status page - http://status.cubecraft.net/ - I suggest you check on that, and if it shows everything is alright, then perhaps its an issue on your side.
     
    IThinkItSucks likes this.
  5. Martinocom

    Martinocom Member

    Joined:
    Apr 10, 2016
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Thanks, guys.

    About my internet connection, I'm pretty sure it's stable. I have an optic fiber connection, I stay 2m from the router and my ping is lowest than 30.
    About the crashes... I just finished an Egg War in map "Rome"; this is the result after the last player die:

    (the first string says "connection lost"; also my friend on VoiP lost connection, before me, during the game)
    [​IMG]
     
  6. JvwerMcGames

    JvwerMcGames Member

    Joined:
    Jan 12, 2016
    Messages:
    451
    Likes Received:
    122
    Trophy Points:
    43
    Gender:
    Male
    Location:
    The Netherlands
    try this:

    -Check that your network connection is enabled, and that no programs are blocking outgoing connections.
    -Try disabling any existing firewall program, or changing its configuration options.
    -Restart your modem/router.

    EDIT: the error in words:

    A DecoderException which is thrown when the received frame data could not be decoded by an inbound handler.
    or
    A DecoderException which is thrown when the length of the frame decoded is greater than the allowed maximum.
     
  7. Martinocom

    Martinocom Member

    Joined:
    Apr 10, 2016
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Just tried a "ping" command to see if there's a problem. For now it seems to be good. No high ping.
    The first is for your server, the second to google server, the third for the router. It's all acceptable, no high pings.

    I'll update if something changes, informing you if it's a "client" or "server" problem.
    [​IMG]
     
  8. JvwerMcGames

    JvwerMcGames Member

    Joined:
    Jan 12, 2016
    Messages:
    451
    Likes Received:
    122
    Trophy Points:
    43
    Gender:
    Male
    Location:
    The Netherlands

    you can try this
    or you can try this

    1. Go into the command prompt
    2. type /co rollback u:{user} t:{Time when they joined}
    3. Press enter
    4. Wait till it shows how long it took to rollback.
    5. Try and join
     
  9. Martinocom

    Martinocom Member

    Joined:
    Apr 10, 2016
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Hi there, I'm here again.
    I tried the first method; well, I'm pretty sure it didn't change anything. I still can play games like Killing Floor 2 (Beta) in a normal way with ping less than 40.

    For the second i don't clearly understand what I must do.

    And... just for closing with style, here is a screen for what happened to me today:
    1) When moving in the Egg Wars lobby it teleports me when I walked in front of game signs.
    2) I can't even join the Tower Defence due the "connection" problem, that I repeat, it's not mine (see the speed test below, ya... sorry for italian)

    [​IMG]

    [​IMG]
     
  10. JvwerMcGames

    JvwerMcGames Member

    Joined:
    Jan 12, 2016
    Messages:
    451
    Likes Received:
    122
    Trophy Points:
    43
    Gender:
    Male
    Location:
    The Netherlands
    time out is definitely your internet connection with the server.
    and sorry the second thing don't work :(
    you can try reinstalling minecraft
    and check your bit operating system with:
    check it here:
    1) right click on my pc
    2) properties (last choice)
    3) check you operating bit system
    64 bit?? download java 64 bit here : http://javadl.oracle.com/webapps/download/AutoDL?BundleId=207231 (direct link)
    32 bit then you have the good java version. (standard version)

    also if you are reinstalling minecraft make sure you delete the VERSIONS folder in %appdata% ---> .minecraft ---> version <--- delete that folder
    and select 1.9.2!

    i hope this will help........

    EDIT: if you install a new version of java (make sure you have the last version....) close seriously everything important: ALL browser, skype and everything that use internet. I'm not sure if java do this automatically??
     
  11. Martinocom

    Martinocom Member

    Joined:
    Apr 10, 2016
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Don't worry. I'm a student of IT at the second year of Bologna's university. I really know what version of SO and java I'm running ;) (also because I have a project to make for an exam, totally in java... so I NEED IT xD)

    This is what happened today:
    I played normally egg wars; a green player come to our base and push me out of map. I should normally respawn, but the screen got crazy and I begin to respawn in the null space, under the map. This is the chat log (as you can see also my friend LaDivisione keep to dying for the same problem).

    (http://wstaw.org/m/2016/04/15/black2.png)
    [​IMG]


    Then the green destroyed our egg and this was the result. I cannot move from them, the cam stay still there and i could only do \leave to leave the game.

    [​IMG]


    ...it's frustrating.

    And about updating/checking java: this was the first thing I've done. First to register here and do this enormous post on this forum; I tried "all I know" to solve the problem on my side.
     
  12. JvwerMcGames

    JvwerMcGames Member

    Joined:
    Jan 12, 2016
    Messages:
    451
    Likes Received:
    122
    Trophy Points:
    43
    Gender:
    Male
    Location:
    The Netherlands

    Help a new bug, can you, @ZacharyJL , report this to the staff??
     
  13. Martinocom

    Martinocom Member

    Joined:
    Apr 10, 2016
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Aaaaaand.... here I'm. Yes: again. This time with a new "bug".

    I just started a "storm" game, in EggWars. Once teleported in map this appears:
    [​IMG]

    It's just continues to "Teleporting to map": you can't select kit and you're continously teleported to your spawn location. No timer.
    The last team remaining wins, even it the map is "crashed", as sperimented.
    Remaining there it became to lag... very... lag.
     
  14. Martinocom

    Martinocom Member

    Joined:
    Apr 10, 2016
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Aaaaaand... just after two games this appears:

    [​IMG]

    "Connection Lost": Current connection force-removed from the remote host. (I don't remember what's the exact translation).

    And this, I'm pretty sure, it's not my problem ;)
     
  15. JvwerMcGames

    JvwerMcGames Member

    Joined:
    Jan 12, 2016
    Messages:
    451
    Likes Received:
    122
    Trophy Points:
    43
    Gender:
    Male
    Location:
    The Netherlands
    This is a known bug. Developers are aware for this bug!

    I found this: (with Goolge) :
    • disable NAT acceleration in my router settings (found in LAN > Switch Control)
    and it fixed all the problems i was experiencing with minecraft server. So good to know it didn't have anything to do with minecraft or Java. The error kicked you out after 15seconds saying this: "internal exception: java.io.ioexception: an existing connection was forcibly closed by remote host"

    Also here for more explanations: http://routerguide.net/nat-acceleration-on-or-off/

    other routers:

    • "NAT acceleration is a feature that is available on Asus branded routers. It is also known as hardware acceleration in some cases by other branded routers. It can also be named as CTF (Cut-Through Forwarding) and FA (Flow Accelerator)."

    • also here about minecraft: "Port Forwarding Not Compatible: NAT Acceleration is reported to not be compatible with port forwarding feature. This means that when you have the NAT Acceleration, you will typically unable to host gaming sessions from your home. So you will not be able to host any game servers such as Minecraft, MMO, or First person shooters since players will not be able to connect to it."
    ~~~ Source: https://www.reddit.com/r/Minecraft/comments/432m1f/fix_for_internal_exception_javaioioexception_an/
     
  16. Martinocom

    Martinocom Member

    Joined:
    Apr 10, 2016
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    I have main ports for Minecraft open (25565), some other ports for other games. Firewall is disabled, by default, and my server for Killing Floor and Minecraft works perfectly, when we play with my friends.
    I can't find the "acceleration NAT" option: my rotuter is a "custom", offered direclty from "Telecom Italia", 'cos I haven't a fibre-ready router at home. I don't think it's present, so.
     
  17. JvwerMcGames

    JvwerMcGames Member

    Joined:
    Jan 12, 2016
    Messages:
    451
    Likes Received:
    122
    Trophy Points:
    43
    Gender:
    Male
    Location:
    The Netherlands
    I CAN'T HANDLE IT!! (sorry)
    I don't know more possible solutions....
    I failed...... I'm so sorry
    maybe (sorry for tagging but....) this people know a other solution....
    @toropov @GingerGeek @Andyschofie Do you know possible answers??
     
  18. Martinocom

    Martinocom Member

    Joined:
    Apr 10, 2016
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Thanks anyway... I just wanna to solve the problem and report you some bugs :)
     
  19. JvwerMcGames

    JvwerMcGames Member

    Joined:
    Jan 12, 2016
    Messages:
    451
    Likes Received:
    122
    Trophy Points:
    43
    Gender:
    Male
    Location:
    The Netherlands
    reporting bugs is very helpful!
    but i can't solve your problem.